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EXCEL 2019 

 Introduction: 

Microsoft Excel 2019 is a spreadsheet program that is used to manage, 
analyze, and present data .it includes many powerful tools that can be used 
to organize and manipulate large amounts of data, perform complex 
calculations, create professional-looking charts, enhance the appearance 

Of worksheets, and more. this handout provides an overview of the excel 
2019 user interface and covers how to perform basic tasks such as starting 
and exiting the program, creating, saving, opening, and closing workbooks, 
selecting cells, entering and editing data, formatting text and numbers, 
positioning cell contents, applying cell styles, and getting help. 

Starting Excel: 

You can start Excel 2019 from the start menu or by double 

Clicking an existing Excel file. When you start the program without opening 

A specific file, the start screen appears, prompting you to open an existing 
workbook or create a new workbook. 

To start Excel 2019 from the start menu: 

1- Click the start menu, click Microsoft Office 2019, 
And then click Excel 2019. The start screen appears (see figure 1). 

2- In the right pane. Click blank workbook opens in the program 
window. 

 

Figure 1- excel 2019 Start Screen 
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Overview of the user interface: 

All the Microsoft Office 2019 programs share a common user interface so 

you can apply basic techniques that you learn in one program to other 

program. The Excel 2019 program window is easy to navigate and simple 

to use (see figure2 and table1). 

 

Figure 2- excel 2019 Program Window 

 

Figure 2: Excel program window 

 

                Table 1-Eexcel Program Window 
Elements 
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Ribbon: 

The Ribbon designed to help you quickly find the commands that you need 
to complete atske.it consist of asset of task-specific tabs. Clicking a tab 
displays asset of related commands that are organized into logical group. 

 

A dialog box launcher appears in the lower-right corner of most 
groups on the ribbon. Clicking it opens a related dialog box or task pane 
that offers additional options. (See figure3-table2) 

You can collapse the Ribbon by clicking the Collapse the Ribbon button 

on the right side of the Ribbon or by double- clicking the current tab. 
When the Ribbon is collapsed, only the names are visible. You can expand 
the Ribbon by double-clicking any tab. 

 

Backstage view: 

The file tab (the first tab on the Ribbon) is used to display the Backstage. View 
which contains all the commands related to managing files and customizing the 
program. It provides an easy way to create, open, save, print…. . 
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To display the Backstage view: 

1. Click the File tab on the Ribbon (see figure 8) 
 

To exit the backstage view: 

1. Click the back button in the upper-left corner of the backstage view or 

press Esc key. (see figure 9) 
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Formula Bar: 

The Formula bar displays the content of the active cell and can be used 
to enter or edit cell contents. The Formula bar contains three buttons (see 
figure 10). The insert button is always available. But the other two buttons 
are active only while you entering or editing data in a cell. Clicking cancels 
button cancels the changes you make in the cell which is the same as Esc 
key. Clicking the Enter Button completes the changes you make in the cell. 
Clicking Insert Function button open a dialog box that helps you construct 
formulas. 

 

Overview of Workbooks: 
An Excel file is called a workbook. Each new workbook contains one blank 
work sheet (see figure 11). You can add additional worksheet or delete 
existing worksheet as needed. By default, a new work book is named 
Book1 and the worksheet it contains is named sheet 1. Each work sheet 
consists of 1,048,576 (numbered)  
rows and 16,384 columns (labeled A  
through XFD). The box formed by  
intersection of row and column is 
called a cell. The active cell has  
green border around it and its name  
appears in the name bar. To know  
the number of rows: ctrl +  .  
To know the number of columns: 
write 1 in A1 cell, click ctrl + shift +     , 
press F2 then click  ctrl + enter. 
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Creating workbooks 

To create a new workbook: 

1. Click the File tab, and click New. 

2. In the right pane, click Blank workbook. 

Note: You can also create a new workbook by pressing Ctrl+N. 

Moving Around in a Worksheet: 
To type in a cell, you must make it the active cell, either by clicking it 
or by using one of the keyboard methods of moving the cell selector. 
Table 10.1 summarizes the keyboard methods. 

 

Selecting Cells, Rows, and Columns: 

In order to work with cell, you must first select it. 

1- To select a single cell: Click the desired 

cell 

2- To select a range of cells: click the first 

cell that you want to include in the range, hold down the Shift key, and 

then click the last cell in the range or drag from the first cell in the range 

to the last cell. 

3- To select nonadjacent cells or range: 

Select the first cell or range, hold down the Ctrl key, and then select the 

other cell or range. 
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To select a single row or column: 

1- Click the header of the row or column that you want to select (see 

figure 21 and figure 22). 

 

 
To select all cells in a worksheet: 

Click the Select ALL button in the upper-left corner of worksheet 

(see figure 23) or press 

CTRL+A. 
 
 
 

 
Entering data: 

You can add data by entering it directly in the cell or by using formula 
bar. A cell contains maximum of 32.767 characters and can hold any 
of three basic types of data: text, numbers, or formulas. 

Entering Text: 

Left-click a cell to select it. Each rectangle in the worksheet is called a cell. 
As you select a cell, the cell address appears in the Name Box. Enter text 
into the cell using your keyboard. The text appears in the cell and in the 
formula bar then press the Enter key. (See figure 24, figure 25) 
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Formating Numbers: 

Modifying a Number Format Use these 
steps to select and then modify a cell’s 
number format: 
1. Select the cell(s) to affect. 
2. On the Home tab, open the Number 
Format drop-down list (in the Number 
group) and select a format, or click the 
Accounting, Percent Style, or Comma 
Style button. 
3. If you want to change the number 
of decimal places, click the Increase Decimal or Decrease Decimal button 
in the Number group. 
4. (Optional) if you want to make other changes to the number format, 
click the dialog box launcher in the Number Group to open the Format 
Cells dialog box (see Figure). 
5. Make any additional number formatting selections as needed. 
6. Click OK. 

NOTE: Formatting does not change the actual value stored in a cell. 

The actual value is used in calculation and is displayed in the Formula bar 
when the cell is selected. 

 
 

Entering Date and times: 

To enter Dates: 

1. Select the cell in which you want to enter the date. 

2. Type the month, day, and year, with each number separated by a 

forward slash (/) or a hyphen (-), and then press the Enter key. 

To enter a Time: 

1. Select the cell in which you want to enter the time. 

2. Type the hour, a colon (:) , and the minutes , press the Spacebar 

,type a for A.M. or P for P.M and then press the Enter key 
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Editing Data: 

To edit data 

1. Double- click the cell that contains the data you want to edit. The 
cursor appears in the cell in the location that you double-clicked. 

2. To insert characters, click where you want to make changes, and 
then type the new characters. 

3. To delete characters, click where you want to make changes, and 
then press the Backspace or Delete key. 

4. When you are finished, press the Enter key. 
5. IF you are editing data and decide not to keep your edits, press the 

ESC key to return the cell to its previous state. 
Clearing Cells: 
You can clear a cell to remove its contents, formats, or comment. 
To clear a cell: 
1- Select the cell that you want to clear. 
2- On Home tab, in Editing group click the 

clear button and select the desired option 
from menu. 

 
Positioing Cell Contents: 

You can change the alignment, indentation and orientation of cell 

content within a cell and merge cell from the Alignment group on home 

tab of the Ribbon contains. 
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Conditional Formatting: 

Easily spot trends and patterns in your data using bars, colors, and icons 

to visually highlight important values. 
 

 
 

Working with Row and Columns: 

Although the number of ROW and Columns is fixed, you can still insert 

rows and column if you need to make 

room for additional data, or delete rows 

or column or hide them, from Home tab, 

cell group there is commands can be 

used. 

Inserting Row and Column 
To insert Row: 
1. Select the row below where you want the new 

row to appear. 

2. Click the Insert command in the Cells group 

on the Home tab. The row will appear. 

To insert Column: 

1. Select the column to the right of where you 

want the column to appear. 

2. Click the Insert command in the Cells group on the Home tab. The 
column will appear. 
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Deleting Rows and Columns 

To delete Row: 

1. Select the row that you want to delete. 

2. From Home tab Insert command in the Cells 

group click delete sheet rows. 

3. You can also delete row by right - clicking the 
row header. 

To delete column: 

1. Select the Column that you want to delete 

2. From Home tab Insert command in the Cells group click delete sheet 

Column. 

3. You can also delete Column by right - clicking the row header. 

 Modifying Columns, Rows and Cells 

To change the Column Width: 

1. Position the cursor over the column line in the column heading and a 

double arrow will appear 

2. Left-click the mouse and drag the cursor to the right to increase the 

column width or to the left to decrease the column width. 
3. Release the mouse button. 

OR 

1. Left-click the column heading of a column 

you'd like to modify. The entire column will 

appear highlighted. 

2. Click the Format command in the Cells 
group on the Home tab. A menu will appear. 

3. Select AutoFit Column Width to adjust the 

column so all the text will fit. 

 

To change the Row Height: 

1. Position the cursor over the row line you want to modify and a double 

arrow will appear. 
2. Left-click the mouse and drag the cursor upward to decrease the row 

height or downward to Increase the row height. 
 

3. Release the mouse button. 
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OR 

a. Click the Format command in the Cells group on the Home tab. A 

menu will appear. 
b. Select AutoFit Row Height to adjust the row so all the text will fit. 

  

 

 

 

Hiding and Unhiding Rows and Columns: 

You can hide rows and columns within a 

worksheet. Hidden rows and column do 

not appear in a printout. 

To hide a row or column: 

1- Select the row or column you want to         

hide. 

2- On the home tab, in the Cell group,    

click format button, point to 

Hide&Unhide. 

3- You can hide row & hide column by 

right –clicking. 
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Renaming Worksheets: To rename a work sheet: 

1- Double –click the tab of the worksheet that you want to 

rename, or right click the sheet tab and then click rename. 

2- Type a new name, and press enter key. 

3- Worksheet name cannot exceed 31 

characters and cannot be blank, each 

worksheet name in a workbook must 

be unique. 

Inserting Worksheets: By default, each new workbook contains one 

worksheet. You can insert additional worksheets as needed. 

To insert a worksheet: 

1- Click the tab of the work sheet to the left of which you want to 

insert a new work sheet. 

2- On Home tab, in the cells group, click the insert arrow, and then 

click Insert Sheet (see figure 16). 
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Deleting Worksheets: 

If you no longer need a worksheet, you can delete it from workbook. 

Deleting a worksheet cannot be undone. 

To delete a worksheet: 

1- Click the tab of the worksheet that 

you want to delete 

2- On the Home tab, in the Cell group, 

click Delete arrow, and then click 

sheet. (see figure 18) 

3- If the work sheet contains data, a dialog box opens asking you to 

confirm. Click delete. 

4- You can also delete worksheet by right click. 

Adding Comments 

You can add a comment to any cell in a work sheet. Excel label each 

new comment by using a name that is specified in the Excel options 

dialog box. 

 

To add a comment: 

1- Select the cell to which you want to add a comment. 
  

2- On the Review tab, in the Comment group, click the new 
 

Comment button . Or right                

click the cell, and then click Insert 

Comment on the shortcut menu. 

3- Type the comment in the 

comment box. 

4- When finished, click any cell in 

the worksheet to hide the comment. A red triangle appears in the 

upper-right corner of the cell to indicate that it contains a 

comment. 
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To edit comment: 

1- Select the cell that you want to edit comment from. 

2- On review tab, in the comment group, click edit comment button 
 

or, right –click the cell, and then click Edit Comment on the 

shortcut menu. 

3- Edit the comment in the comment box. 
4- When finished, click any cell in the worksheet to hide the 

comment 

Deleting Comments 

To delete comment that you are no longer needed: 

1. Select the cell that you want to delete comment from. 

 
2. On the Review tab, in the Comment group, click Delete button . 
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Relative, Absolute and Mixed Cell References in Excel 

A worksheet in Excel is made up of cells. These cells can be 

referenced by specifying the row value and the column value. 

For example, A1 would refer to the first row (specified as 1) and the 

first column (specified as A). Similarly, B3 would be the third row and 

second column. The power of Excel lies in the fact that you can use 

these cell references in other cells when creating formulas.  

Now there are three kinds of cell references that you can use in 

Excel: 

• Relative Cell References 

• Absolute Cell References 

• Mixed Cell References 

Understanding these different types of cell references will help you 

work with formulas and save time (especially when copy-pasting 

formulas). 

A cell reference or cell address is a combination of a column letter 

and a row number that identifies a cell on a worksheet. 

For example, A1 refers to the cell at the intersection of column A and 

row 1; A3 refers to the column A and row 3, and so on. 

 

When used in a formula, cell references help Excel find the values 

the formula should calculate. 

For instance, to pull the value of A1 to another cell, you use this 

simple formula: 

= A1 

To add up the values in cells A1 and A2, you use this one: 

= A1+A2 
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Relative cell reference 

A relative reference is the one without the $ sign in the row and 

column coordinates, like A1 or A1:B10. By default, all cell addresses 

in Excel are relative. 

When moved or copied across multiple cells, relative references 

change based on the relative position of rows and columns. So, if you 

want to repeat the same calculation across several columns or rows, 

you need to use relative cell references. 

For example, to multiply numbers in column A by 5, you enter this 

formula in B2: 

=A2*5 

When copied from row 2 to row 3, the formula will change to: 

=A3*5 

 

Absolute cell reference  

An absolute reference is the one with the dollar sign ($) in the row 

or column coordinates, like $A$1 or $A$1:$B$10. 

An absolute cell reference remains unchanged when filling other 

cells with the same formula. Absolute addresses are especially useful 

when you want to perform multiple calculations with a value in a 

specific cell or when you need to copy a formula to other cells 

without changing references. 

For example, to multiply the numbers in column A by the number in 

B2, you input the following formula in row 2, and then copy the 

formula down the column by dragging the fill handle: 

=A2*$B$2 

The relative reference (A2) will change based on a relative position 

of a row where the formula is copied, while the absolute reference 

https://www.ablebits.com/office-addins-blog/2016/01/20/copy-formula-excel/#copy-formula-column-down
https://www.ablebits.com/office-addins-blog/2016/01/20/copy-formula-excel/#copy-formula-column-down
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($B$2) will always be locked on the same cell: 

 

Mixed cell reference 

A mixed reference contains one relative and one absolute 

coordinate, like $A1 or A$1. 

There may be many situations when only one coordinate, column or 

row, should be fixed. 

For example, to multiply a column of numbers (column A) by 3 

different numbers (B2, C2 and D2), you put the following formula in 

B3, and then copy it down and to the right: 

=$A3*B$2 

In $A3, you lock the column coordinate because the formula should 

always multiply the original numbers in column A. The row 

coordinate is relative since it needs to change for other rows. 

In B$2, you lock the row coordinate to tell Excel always to pick the 

multiplier in row 2. The column coordinate is relative because the 

multipliers are in 3 different columns and the formula should adjust 

accordingly. 

As the result, all the calculations are performed with a single 

formula, which changes properly for each row and column where it 

is copied: 
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Working with Views: 

Excel provides several ways in which you can view worksheets. 
 

Switching Views: 

Excel offers a variety of viewing that change how a worksheet is 

displayed on the screen. (See table 1) 

 To switch Views: 

1- On the View tab, in the Workbook Views group, click the desired view 

button (see figure 29). 

2- Or click the desired view button on View Shortcuts toolbar located on 

the right side of the Statues bar (see figure 30). 
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Freezing Panes: 

Freezing Panes is a useful technique for keeping an area of a worksheet 

Visible while you scroll to another area of the worksheet. You can freeze 

only rows at the top and 

column on the left side of 

the worksheet, you cannot 

freeze rows and columns 

in the middle of the 

worksheet. Excel displays dark gray lines to indicate frozen row and 

column (see figure). 

To freeze panes: 

1- Select the cell below the row and 

to the right of the column that you 

want to freeze. 

2- On the View tab, in the Window 

group, click the Freeze panes 

button, and then click Freeze Pane. 

3- When any row or column are 

frozen, the Freeze Panes option 

changes to Unfreeze Pane. 
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Changing the page Layout 

The commands used to define the layout of a printed page are available 

on the Page Layout tab of the Ribbon. 
 

 

Changing the page margins: 

To change the page margins: 

1- Select the work sheet for which you want to change the margins. 

2- On the page layout tab, in the page setup group, click the Margins 

button and select the desired margin setting from the menu. 
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Changing the Page Orientation: 

In Excel, you can print a worksheet in either portrait or landscape 

orientation. 

To change the page orientation: 

1- Select the work sheet for which you want to change the orientation. 

2- On the page layout tab, in the page setup group, click the Margins 
orientation button and then select the click either portrait or landscape. 

 

Setting a print Area: 

By default, Excel print the entire worksheet. If you frequently print a 

specific section of worksheet. You can set a print area that includes just 

that section. That way, when you print the worksheet, only that section 

will print. 

To set a print area: 

1-Select the cells that you want to define as the print area. 

2- On the page layout tab, in the page 

setup group, click the print Area button and 

then click set print Area. 

3- You can clear the print area by clicking 

the Print Area button, and then clicking 

Clear Print Area. 
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Printing Gridlines: 

Gridlines are the light gray lines that appear around cells in a 

worksheet. By default, gridline is displayed on the screen, but they are 

not printed. You can choose to print a worksheet with gridlines that 

make the data easier to red on a printed page. 

To print gridlines: 

1- Select the worksheet that you 

want to print with gridlines. 

2- On the page layout tab, in the 

sheet options group, under 

gridlines, select the print check box. 

Sheet direction: 

Normally, the worksheet direction is Left-to-Right in Excel, but in order to 
satisfy certain language writing habits from right to left, Excel can switch 
direction of the worksheet which place the row and column heading on 
right as following screenshots shown. From Page Layout tab, sheet option 
click sheet Right to left. 

 

Previewing and print worksheets: 

Before printing a worksheet, you can preview it to see how each page 

Will look when printed. The print page of backstage view allows you to 

preview a worksheet. 
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To preview and print a worksheet: 

1- Select the worksheet that you want to preview and print. 

2- Click the File tab, and then click Print, or press CTRL+P the print page 

of the Backstage view opens, displaying print setting in the center pane 

and preview of the worksheet in the right pane. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



First stage: Software Department; College of Computer 

Science and Mathematics; University of Mosul 

Computer Science/ 
Lecturer: Assist.Prof. Baydaa Sulaiman  

 
 
 

                                                                                              

 
 
 

Sorting data by a Single Column: 

To sort the data in wok sheet by a single column. 

1- Select a cell in the column that you want to sort 

by. 

2- On the Data tab, in the Sort& Filter group, do one 

of the following: 

a-To sort in ascending order, click the Ascending button . 

b- To sort descending order, click the Descending button.  

Entering data using Auto Fill 

The Auto Fill feature automatically fills in data based on the data in 
adjacent cells. You can use it to enter data in a series (such as months, days 
of the week, and quarters). Or copy values to formulas to adjacent cell. To 
enter data using auto fill: 

1- Select the cell that contain the first value of a series you want to 

extend or the data you want to copy. 

2- Point to the Fill handle (the green square) in the lower-right corner of 

the selected cell. The mouse pointer changes to a black plus sign 

 
 

 
3- Drag the Fill handle over the cell that you want to fill. As you drag, screen 

tip appears showing the data that will be entered in each cell. 

4- Release the mouse button. Excel fills the cells based on the contents of 

the first cell, the Auto Fill option button appears in the lower- right corner 

of the last cell. 
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Filtering Cells 
Filtering or temporarily hiding data in a spreadsheet very easy. This 
allows you to focus on specific spreadsheet entries To Filter Data: 

1. Select a cell within the range that you want to filter 
2. On the data tab, in the Sort& Filter group, click filter button (see 

figure3). Filter arrows appear to each column heading (see 
figure4). 

 

3. deselect the (select All) check box at the top of the list and then 

select check box next to the value you want. 
 

To Clear One Filter: 

1. Select one of the drop-down arrows next to a filtered column. 

2. Choose Clear Filter From... 

3. To remove all filters, click the Filter command. 



First stage: Software Department; College of Computer 

Science and Mathematics; University of Mosul 

Computer Science/ 
Lecturer: Assist.Prof. Baydaa Sulaiman  

 
 
 

                                                                                              

 
 

 

Working with charts: 

A chart is a graphical representation of numerical data. You use chart to 

make it easier to spot trends, highlight important changes, or compare 

individual figures. A chart is composed of many element, some of these 

element are displayed by default, others can be added as needed. You 

can also remove chart element that you do not want to display. Not all 

elements appear in every chart type. 
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When a chat is selected, the chart tools contextual tabs 
(Design and Format) become available on the Ribbon. You can use the 
commands on these tabs to change the design, and appearance of the 
chart. 

 

When a chart is selected, three buttons appear in the upper-right corner 

of the chart. These Buttons provide quick access to the most common 

and useful chart customization features. 
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Chart Elements 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 

 
Chart Styles 
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To create a chart: 

1- Select the cells that contain the 

data you want to include in the 

chart. 

2- On the insert tab, in the Charts 

group, click the chart type that 

you want to use, and then click the desired chart subtype. The chart 

appears in the worksheet. 

 
To create a recommended chart: 

1- Select the cells that 

contain the data you want 

include in the chart. 

2- On the Insert tab, in the 

chart group, click the 

recommended Charts button 

. 

3- In the insert chart dialog 

box, on the 

Recommended Charts tab. 

Select one of the recommended chart in the left pane, and then click the 

OK button. 

Change the chart type: 

1- Select the chart you want to change. 

2- Under chart tool, on the Design tab, in the Type group, click the 

change chart type button  
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3- In the change chart type, Select the desired chart in the left 

pane, select the desired chart subtype in the right pane, and 

then click OK button. 
 

filter a chart : 

To filter a chart 

1- Select the chart that you want to 

filter. 

2-  Click the chart Filter button next 

to the chart, deselect the check boxes 

next to series or categories that you 

want to hid, and then click the Apply 

button. 

Format chart style 

1. Select the chart you want to format. 

2.do one of the following: 

• Under the Chart Tool, on the Design tab, in the Chart style 

group, and then click the desierd style. 

• Click the Chart style button   next to chart, and then 

click  the desired style on the Style tab of the Chart styles 

gallery 
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Deleting Chart:If you no longer need a chart, you can delete it from the 

work book by select the chart you want to delete and press Delete key. 

To delete the chart sheet Right click on sheet tab and click delete. 
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Using Formulas and Functinos: 
Formulas are used to perform calculation in work sheet. All Formulas 

must begin with an equal sign(=). Formulas can consist of the following 

elements: 
 

1.Constsnt values (such as 5 or 100) 

2.Cell references (such as A1 or A1:A3) 

3.Operations (such as+ for addition or* for muliplication) 

4.Functions (such as SUM or AVERAGE). 

Using Operator in Formulas: 

Operators are symbols that represent specific mathematical operation 

excel formulas support a variety of operations (see table below). 

 

Entering Simple Formulas: 

To enter a formula 

1. Select the cell in which you want to enter the formula. 
2. Type an equal sign (=). 
3. Enter the first value or cell reference. 
4. Enter the desired operation. 
5. Enter the next value or cell reference. 
6. Repeat steps 4 and 5 as needed to complete the formula. 
7. When finished, press the Enter key. The result of formula 

appears in the cell. 
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Using the Auto Sum Button: 

The Auto Sum button provides quick access to the most commonly used 

functions. To sum number using the Auto Sum button: 

1. Select a cell next to the number that you want to sum. 

2. On Home tab, in the editing group, click the Auto Sum 

button (see figure 39) 

3. Do one of the following: 

a. If the suggested range is correct, press the enter key to display the 
result. 

b. if the suggested range is incorrect, select the correct range, and 
then press Enter key to display the result. 

 



First stage: Software Department; College of Computer 

Science and Mathematics; University of Mosul 

Computer Science/ 
Lecturer: Assist.Prof. Baydaa Sulaiman  

 
 

 

 
 

Insert Function: 
 

To insert a function: 

1. Select the cell in which you want to enter the formula. 

2. On the Formula tab, in the function library group, click the Insert 

Function button  .or click the insert function button on the Formula 

bar. 
 

3. In the Insert Function dialog box, search for a function or select a 

category, select the desired function, and then click the OK button 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
. 

4. In the function arguments dialog box, enter the functions arguments 

and then click OK button to display the result. (see figure) 
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Most Common Excel Errors and Resolve Them 

1. ###### Error (#######) 

This is one of the most common and easiest to tackle error. Basically, it is 
not a formula-based error but occurs when the width of column is small. In 
the example below, the figure 15000000 is too big and the column width is 
too small and hence it shows a error. 

 
When you increase the width of column A, you will see that the error 
disappears. 
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2. Name Error ( #NAME? ) 

This error arises whenever Excel is not able to recognize the text in the 
formula. Like in the example below, instead of writing SUM we have written 
su and that is the reason we see the #NAME? in A5. 

 
You will see that when you have corrected the formula to =SUM(A1:A4), 
you get the correct answer. 

 
3. Value Error ( #VALUE! ) 

Excel shows a Value error whenever the variable mentioned in the formula 
is wrong. If you see the image below, you will notice that in the formula cell 
A4 contains text whereas the other 3 cells contain numerical values and 
hence there is an #VALUE! Error. 

 
When you change the formula to A1+B1+C1 then you shall receive the 
correct answer without any errors. 
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4. Division Error ( #DIV?0! ) 

This is very simple to remember. When you attempt to divide a number by 
zero, you will come across the #DIV/0! error. In the example below, A4 cell 
contains a 0 and that is the reason the result for A1/A4 is #DIV/0! Error. 

 
When you replace the zero with any other number ( 5 in our example), you 
will see the actual result without any error. 

 
5. Null Error ( #NULL! ) 

This is one of the most common types of error. When you forget to 
separate the two cell references correctly, then you shall receive this error. 
In the below mentioned example, there is no command between the cell A4 
and A4 and hence, you see the #NULL! Error. 
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When you add a proper command between the two cell references, then 
you will get your desired result without any error. 

 
6. Reference Error ( #REF! ) 

When your formula contains some incorrect cell references, then you shall 
see a Reference Error. This mainly happens when you mistakenly delete any 
row or column. In the example below, you will see that your data is 
perfectly filled without any errors. 

 
If by chance I delete the 3rd row, then the reference error shall occur as the 
original formula contains the value of 3rd row. 

 
 

 


