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introduction 

Until now, you have focused on project 
planning—developing and communicating the 
details of a project plan before actual work 
begins. When work begins, so does the 
next phase of project management: tracking 
progress. Tracking means recording project 
details such as when the work was done, and at 
what cost. These 
details are often called actuals. 

 
 

 



introduction 
Tracking actuals is essential to properly managing, as opposed 
to just planning, a project. The project manager must know 
how well the project team is performing and when to take 
corrective action. Properly tracking project performance and 
comparing it with the original plan allows you to answer such 
questions as the following: 
● Are tasks starting and finishing as planned? If not, what will 
be the impact on the project’s finish date? 
● Are resources spending more or less time than planned to 
complete tasks? 
● Are higher-than-anticipated task costs driving up the overall 
cost of the project? 
 



introduction 
before you begin tracking progress, you should determine the 
level of detail you need. The different levels of tracking detail 
include the following: 
● Record project work as scheduled. This level works best if 
everything in the project occurs exactly as planned. 

● Record each task’s percentage of completion, as increments 
such as 25, 50, 75, or 100 percent. 

● Record the actual start, actual finish, actual work, and 
actual and remaining duration for each task or assignment. 
Because different portions of a project might have different 
tracking needs, you might need to apply a combination of 
these approaches within a single project plan. 
 
 
 



 
 
Saving a Project Baseline 
 
 

 
 

After developing a project plan, one of a project manager’s 
most important activities is to record actuals and evaluate 
project performance. To judge project performance 
properly, it is helpful to compare it with your original plan. 
This original plan is called the baseline plan, or just the 
baseline. A baseline is a collection of important values in a 
project plan such as the planned start dates, finish dates, 
and costs of the tasks, resources, and assignments. When 
you save a baseline, Project takes a “snapshot” of the 
existing values and saves it in your Project plan for future 
comparison. 
 
 



 
Saving a Project Baseline 
 
  

 

Project supports not just 1 but up to 11 baselines in a 
single plan. The fist one is called Baseline, and the rest are 
Baseline 1 through Baseline 10. Saving multiple baselines 
can be useful for projects with especially long planning 
phases in which you might want to compare different sets 
of baseline values. For example, you might want to save 
and compare the baseline plans every month as the 
planning details change. 
 
 
 



 
Saving a Project Baseline 
 
 The specific values saved in a baseline include the task, 

resource, and assignment fields, as well as the timephased 
fields. 
 

 

 

Tip Timephased fields show task, resource, and assignment 
values distributed over time. For example, you can look at a 
task with five days of work planned at the weekly, daily, or 
hourly level and see the specific baseline work values per 
time increment.  
 
 

 
 



 
Saving a Project Baseline 
 
 

then follow these steps. 
1. On the File tab, click Save As. 
Project displays the Save As dialog box. 
2. In the File name box, type Simple Tracking, and then click 
Save. 
3. On the Project tab, in the Schedule group, click Set 
Baseline, and then click SetBaseline. 
The Set Baseline dialog box appears. 

4. Click OK. 
Project saves the baseline, even though there’s no indication 
in the Gantt Chart view that anything has changed. You will 
now see some of the changes caused by saving the baseline. 
 
 
 
 

 
 



 
Saving a Project Baseline 
 
  

 

 
 

5. On the View tab, in the Task Views group, click Other 
Views and then click Task Sheet. 
 
 



 
Saving a Project Baseline 
 
 

The Task Sheet view appears. Now you’ll switch to the 
Variance table in the Task Sheet view. The Variance table is 
one of several predefined tables that include baseline values. 

6. On the View tab, in the Data group, click Tables. 
In the listed tables, note the check mark next to Entry. This 
means that the Entry 
table is currently displayed in the Task Sheet view.  
7. Click Variance. 
This table includes both the scheduled and baseline 
start and finish columns, shown side by side for easy 
comparison. 
 
 
 
 

 
 



 
Saving a Project Baseline 
 
 

 
 
 
 

 
 



 
Saving a Project Baseline 
 
 

 
 
 
 

 
 

Because no actual work has occurred yet and no changes 
to the scheduled work have been made, the values in the 
Start and Baseline Start fields are identical, as are the 
values in the Finish and Baseline Finish fields. After actual 
work is recorded or later schedule adjustments are made, 
the scheduled start and finish values might differ from the 
baseline values. You would then see the differences 
displayed in the variance columns. 
8. On the View tab, in the Task Views group, click Gantt 
Chart. The Gantt Chart view appears. 
 
 



 
 
Tracking a Project as Scheduled 
 
 

 
 
 
 

 
 

The simplest approach to tracking progress is to report 
that the actual work is proceeding exactly as planned. For 
example, if the fist month of a fie-month project has 
elapsed and all its tasks have started and finished as 
scheduled, you can quickly record this in the Update 
Project dialog box. When you record progress through a 
specific date, Project calculates actual duration, remaining 
duration, actual costs, and other values up 
to the date you entered. 
 
 
 
 



 
 
Tracking a Project as Scheduled 
 
 

 
 
 
 

 
 

In this exercise, you record project actuals by updating 
work to a specific date. 
1. On the Project tab, in the Status group, click Update 
Project. 
The Update Project dialog box appears. 
2. Make sure the Update work as complete through 
option is selected. In the adjacent date box, type or select 
the date for example: 1/11/12 
 
 
 
 
 



 
 
Tracking a Project as Scheduled 
 
 

 
 
 
 

 
 

In this exercise, you record project actuals by updating 
work to a specific date. 
1. On the Project tab, in the Status group, click Update 
Project. 
The Update Project dialog box appears. 
2. Make sure the Update work as complete through 
option is selected. In the adjacent date box, type or select 
the date for example: 3/16/2000 
 
 
 
 
 



 
 
Tracking a Project as Scheduled 
 
 

 
 
 
 

 
 

3. Click OK. 
Project records the completion percentage for the tasks that 
were scheduled to 
start before 3/16/2000. It displays that progress by drawing 
progress bars in the Gantt bars for those tasks. 
 
 
 
 
 



 
 
 
Entering a Task’s Completion Percentage 
 
 
 

 
 
 
 

 
 

After work has begun on a task, you can quickly record its 
progress as a percentage. 
When you enter a completion percentage other than 0, 
Project changes the task’s actual start date to match its 
scheduled start date. 
For example, if you specify that a four-day task is 50 percent 
complete,  
Project calculates that it has had two days of actual duration 
and has two days of remaining duration. 
 



 
 
 
Entering a Task’s Completion Percentage 
 
 
 

 
 
 
 

 
 

Here are some ways of entering completion percentages: 
● Use the 0%, 25%, 50%, 75%, and 100% Complete buttons 
in the Schedule group of 
the Task tab. 
● Enter any percentage value you want in the Update Tasks 
dialog box (to access this dialog box, on the Task tab, in the 
Schedule group, click the down arrow to the 
right of the Mark on Track, and then click Update Tasks). 
 
 
 
 
 
 



 
 
 
Entering a Task’s Completion Percentage 
 
 
 

Tip: 
 You can also set percent complete by pointing to a 
Gantt bar (or progress bar within a Gantt bar).  
When the mouse pointer changes to a percent 
symbol and right arrow, 
drag the mouse pointer from left to right within the 
Gantt bar.  
As you do so, note the “complete through” date 
value that appears in a ScreenTip. 
 
 



 
 

Entering Actual Values for Tasks 
 
 

A more detailed way to keep your schedule up to date is to record 
what actually happens for each task in your project. You can record 
each task’s actual start, finish, work, 
and duration values. When you enter these values, Project uses the 
following rules: 
 
● When you enter a task’s actual start date, Project moves the 
scheduled start date to match the actual start date. 
 
● When you enter a task’s actual finish date, Project moves the 
scheduled finish date to match the actual finish date and sets the task 
to 100% complete. 
 
● When you enter a task’s actual duration, if it is less than the 
scheduled duration, Project subtracts the actual duration from the 
scheduled duration to determine the remaining duration. 
 
 
 
 



 
 

Entering Actual Values for Tasks 
 
 

• When you enter a task’s actual duration, if it is equal to the 
scheduled duration, Project sets the task to 100% complete. 

•  When you enter a task’s actual duration, if it is longer than the 
scheduled duration, Project adjusts the scheduled duration to 
match the actual duration and sets the task to 100% complete. 

 

In this exercise, you record actual work values for some tasks as well 
as start dates and durations for other tasks. 
1. On the View tab, in the Data group, click Tables and then click 
Work. The Work table appears. 

 
 
 
 
 



 
 

Setting Task Constraints 
 
 

Every task that you enter into Project has some type of constraint 
applied to it. A constraint controls the start or finish date of a task 
and the degree to which that task can be rescheduled. There are 
three categories of constraints: 
 
 
Flexible constraints Project can change the start and finish dates 
of a task. The default constraint type in Project is that tasks start 
as soon as possible. This type of flexible constraint is called As 
Soon As Possible, or ASAP for short. No constraint 
date is associated with flexible constraints. Project does not 
display any special indicator in the Indicators column for flexible 
constraints. 
 
 



 
 

Setting Task Constraints 
 
 

Inflexible constraints A task must begin or end on a certain date. 
For example, you can specify that a task must end on November 9, 
2012. Inflexible constraints are sometimes called hard constraints. 
When an inflexible constraint has been applied to a task, Project 
displays a special indicator in the Indicators column. You can point 
to a constraint indicator. 
 Semi-flexible constraints A task has a start or finish date boundary. 
However, within that boundary, Project has the scheduling flexibility 
to change the start and finish dates of a task. For example, let’s say 
a task must finish no later than April 15,2023. However, the task 
could finish before this date. Semi-flexible constraints are 
sometimes called soft or moderate constraints. When a semi-
flexible constraint has been applied to a task, Project displays a 
special indicator in the Indicators column. 
 
 



 
 

Setting Task Constraints 
 
 



 
 

Setting Task Constraints 
 
 



 
 

Setting Task Constraints 
 
 

These three constraint categories have very different effects on the 
scheduling of tasks: 
● Flexible constraints, such as ASAP, allow tasks to be scheduled 
without any limitations other than their predecessor and successor 
relationships, and the project’s start date (for ASAP task constraints) 
or finish date (for ALAP task constraints). No fixed start or end dates 
are imposed by these constraint types. Use these constraint 
types whenever possible. 



 
 

Setting Task Constraints 
 
 

• Semi-flexible constraints, such as Start No Earlier Than or Start No 
Later Than, limit the rescheduling of a task within the date boundary 
that you specify. 

● Inflexible constraints, such as Must Start On, prevent the 
rescheduling of a task. Use these constraint types only when absolutely 
necessary. 



 
 

Setting Task Constraints 
 
 

In this exercise, you apply a constraint to a task. 
1. Select the name of task. 
2. On the Task tab, in the Editing group, click Scroll to Task 

The resource that work on this task , informed you that due to his travel 
schedule, he will be unable to start the task (before April 18—later than 
currently scheduled.(Train support staff 17-21 April) 
 
3. On the Task tab, in the Properties group, click Information. 
4. In the Task Information dialog box, click the Advanced tab. 
5. In the Constraint Type box, select Start No Earlier Than. 
6. In the Constraint Date box, type or select 13/4/2023, and then click OK. 
 
 
 
 
 

 

 



 
 

Setting Task Constraints 
 
 

 
 
 

 

 

Type 18-4-2023 in constraint date 



 
 

Setting Task Constraints 
 
 

 
 
 

 

 

التابعة لها، ولو    summery taskملاحظة انه تمت اعادة الجدولة لهذه المهمة وللـ 

كان هناك مهام تعتمد على هذه المهمة ، فكل المهام سيتم اعادة جدولتها ويظهر عليها 
 تظليل



 
 

Setting Task Constraints 
 
 

 
 
 

 

 



 
 

Setting Task Constraints 
 
 

 
 
 

 

 



 
 

Setting Task Constraints 
 
 

 
 
 

 

 



 
 

Setting Task Constraints 
 
 

 
 
 

 

 



 
 

Setting Task Constraints 
 
 

 
 
 

 

 


