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Introducing the Excel
• The figure shows you the different parts of  the screen. Here are shorthand descriptions of  these screen parts:

• Quick Access toolbar: This toolbar offers the Save, Undo, Repeat, and Customize buttons. Wherever you go in Excel, you see the Quick 

Access toolbar.

• Minimize, Restore, Close buttons: These three magic buttons make it very easy to shrink, enlarge, and close the window you are 

working in.

• File tab: Go to the File tab to do file-management tasks.

• The Ribbon: Select a tab on the Ribbon to undertake a new task.

• View buttons: Click one of  these buttons — Normal Mode, Page Layout, or Page Break Review— to change your view of  a sheet.

• Zoom controls: Use these controls to zoom in and out on your work.



Introducing the Excel

• Workbook is the Excel term for the files you create with Excel. 
When you create a workbook, you are given the choice of  creating a 
blank workbook or creating a workbook from a template. Each 
workbook comprises one or more worksheets.

• A worksheet, also known as a spreadsheet, is a table into which you 
enter data and data labels. The worksheet is divided by gridlines into 
columns (A, B, C, and so on) and rows (1, 2, 3, and so on).

• The rectangles where columns and rows intersect are cells, and each 
cell can hold one data item, a formula for calculating data, or nothing 
at all. Each cell has a different cell address.
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Creating a New Worksheet

• Follow these basic steps to create a workbook:

• 1. On the File tab, choose New.

• The New window shown in Figure appears.

• 2. Click to select a template.

• A preview window appears with a description of  the template you chose, Click the 

Create button in the preview window.

• Your new workbook opens.





Rows, columns, and cell addresses

• An Excel worksheet has numerous columns and more than 1 million rows.

• The rows are numbered, and columns are labeled A to Z, then AA to AZ, then BA to BZ, 
and so on

• The important thing to remember is that each cell has an address whose name comes 
from a column letter and a row number..

• The first cell in row 1 is A1, the second is B1, and so on. You need to enter cell addresses in 
formulas to tell Excel which numbers to compute.

• The left side of the Formula bar lists the address of the active cell, the cell that is selected 
in the worksheet.



Workbooks and worksheets

• By default, each workbook includes one worksheet, called Sheet1, but you can add more 
worksheets (and rename worksheets, too).



Entering Data in a Worksheet

• What you can enter in a worksheet cell falls into four 
categories:
➢Text

➢A value (numeric, date, or time)

➢A logical value (True or False)

➢A formula that returns a value, logical value, or text



Entering Data in a Worksheet

• No matter what type of data you’re 
entering, the basic steps are the same:

1) Click the cell where you want to enter the 
data or text label.

• As shown in figure, a square appears around 
the cell to tell you that the cell you clicked is 
now the active cell. 

• Glance at the left side of the Formula bar if 
you’re not sure of the address of the cell 
you’re about to enter data in. The Formula bar 
lists the cell address.



Entering Data in a Worksheet

2) Type the data in the cell.

• If you find typing in the Formula bar 
easier, click and start typing there.



Entering Data in a Worksheet

3) Press the Enter key to enter the number or 
label.

• Besides pressing the Enter key, you can also 
press an arrow key (←, ↑, →, ↓), press Tab, 
click the Enter button (the check mark) on the 
Formula bar, or click elsewhere on the 
worksheet. 

• If you change your mind about entering data, 
click the Cancel button or press Esc to delete 
what you entered and start over. The Cancel 
button (an X) is located on the Formula bar 
next to the Enter button (a check mark) and 
the Insert Function button (labeled fx).



Entering Data in a Worksheet



Entering text labels

• Sometimes a text entry is too long to fit in a cell. How Excel accommodates text entries that are too wide 
depends on whether data is in the cell to the right of the one you entered the text in:

➢ If the cell to the right is empty, Excel lets the text spill into the next cell.

➢ If the cell to the right contains data, the entry gets cut off. Nevertheless, the text you entered is in the cell. 
Nothing gets lost when it can’t be displayed onscreen. You just can’t see the text or numbers except by 
glancing at the Formula bar, where the contents of the active cell can be seen in their entirety.

• Use these techniques to solve the problem of text that doesn’t fit in a cell:

➢Widen the column to allow room for more text.

➢ Shorten the text entry.

➢Wrap the contents of the cell. Wrapping means to run the text down to the next line, much the same way as 
the text in a paragraph runs to the next line when it reaches the right margin. Excel makes rows taller to 
accommodate wrapped text in a cell. To wrap text in cells, select the cells, go to the Home tab, and click the 
Wrap Text button (found in the Alignment group).



Entering numeric values

• When a number is too large to fit in a cell, Excel displays pounds signs (###) instead of a number 
or displays the number in scientific notation (8.78979E+15). 

• You can always glance at the Formula bar, however, to find out the number in the active cell. As 
well, you can always widen the column to display the entire number.

• To enter a fraction in a cell, enter a (0) or a whole number, a blank space, and the fraction. 

• For example, 

• to enter 3⁄8, type a 0, press the spacebar, and type 3/8. 

• To enter 53⁄8, type 5, press the spacebar, and type 3/8. 

• For its purposes, Excel converts fractions to decimal numbers, as you can see by looking in the 
Formula bar after you enter a fraction. For example, 53⁄8 displays as 5.375 in the Formula bar.



Entering date and time values

• Dates and times can be used in calculations, but entering a date or time value in a 
cell can be problematic because these values must be entered in such a way that 
Excel can recognize them as dates or times, not text.

• Excel converts dates and times to serial values for the purpose of being able to use 
dates and times in calculations. 

• For example, July 31, 2004, is the number 38199. July 31, 2004, at noon is 
38199.5. 

• These serial values represent the number of whole days since January 1, 1900. The 
portion of the serial value to the right of the decimal point is the time, represented 
as a portion of a full day.



Entering date and time values



Entering date values

• Entering date values
• You can enter a date value in a cell in just about any format you 

choose, and Excel understands that you’re entering a date. For 
example, enter a date in any of the following formats and you’ll be 
all right:



Entering date values

➢ Date formats: You can quickly apply a format to dates by selecting cells and using one of these techniques:

❑On the Home tab, open the Number Format drop-down list and choose Short 
Date (m/d/yyyy; 7/31/2016) or Long Date (day of the week, month, day, year; 
Wednesday, July 31, 2016), as shown in Figure 1-5.

❑On the Home tab, click the Number group button to open the Number tab of the Format Cells dialog box. As 
shown in Figure 1-5, choose the Date category and then choose a date format.

➢ Current date: Press Ctrl+; (semicolon) to enter the current date.

➢ Current year’s date: If you don’t enter the year as part of the date, Excel assumes that the date you entered 
is in the current year. 

❑For example, if you enter a date in the m/d (7/31) format during the year 2025, Excel enters the date as 
7/31/25.



Entering date values

• Dates on the Formula bar: No matter which format you use for dates, dates are 
displayed in the Formula bar in the format that Excel prefers for dates: m/d/yyyy 
(7/31/2021). How dates are displayed in the worksheet is up to you.

• Dates in formulas: To enter a date directly in a formula, enclose the date in 
quotation marks. (Make sure that the cell where the formula is entered has been 
given the Number format, not the Date format.) 

• For example, the formula =TODAY()-“1/1/2021” calculates the number of days 
that have elapsed since January 1, 2021.



Entering time values

• Excel recognizes time values that you enter in the following ways:

• Here are some things to remember when entering time values:

➢ Use colons: Separate hours, minutes, and seconds with a colon (:).

➢ Time formats: To change to the h:mm:ss AM/PM time format, select the cells, go to the Home tab, open the 
Number Format drop-down list, and choose Time (see Figure 1-5). You can also change time formats by 
clicking the Number group button on the Home tab and selecting a time format on the Number tab of the 
Format Cells dialog box.

➢ AM or PM time designations: Unless you enter AM or PM with the time, Excel assumes that you’re 
operating on military time. For example, 3:30 is considered 3:30 a.m.; 15:30 is 3:30 p.m. Don’t enter periods 
after the letters am or pm (don’t enter a.m. or p.m.).



Entering time values

➢Current time: Press (Ctrl+Shift+;) (semicolon) to enter the current 
time.

➢Times on the Formula bar: On the Formula bar, times are displayed 
in this format: hours:minutes:seconds, followed by the letters AM or 
PM. However, the time format used in cells is up to you.



Quickly Entering Lists and Serial Data with the AutoFill Command

• Data that falls into the “serial” category — month names, days of the week, and 
consecutive numbers and dates, for example — can be entered quickly with the AutoFill 
command.

1) Click the cell that is to be first in the series. For example, if you intend to list the days 
of the week in consecutive cells, click where the first day is to go.

2) Enter the first number, date, or list item in the series.

3) Move to the adjacent cell and enter the second number, date, or list item in the 
series. If you want to enter the same number or piece of text in adjacent cells, taking 
this step isn’t necessary, but Excel needs the first and second items in the case of serial 
dates and numbers so that it can tell how much to increase or decrease the given amount 
or time period in each cell. For example, entering 5 and 10 tells Excel to increase the 
number by 5 each time so that the next serial entry is 15.



Quickly Entering Lists and Serial Data with the AutoFill Command

3) Select the cell or cells you just entered 
data in. To select a single cell, click it; to 
select two, drag over the cells.

4) Click the AutoFill handle (mouse 
cursor turns to a black solid cross) and 
start dragging in the direction in which 
you want the data series to appear on 
your worksheet. The AutoFill handle is 
the little green square in the lower-right 
corner of the cell or block of cells you 
selected. As you drag, the serial data 
appears in a pop-up box, as shown in 
figure



Formatting Numbers, Dates, and Time Values

• When you enter a number, that Excel recognizes as belonging to one of its 
formats, Excel assigns the number format automatically. Enter 45%, for 
example, and Excel assigns the Percentage number format. 

• Enter $4.25, and Excel assigns the Currency number format. 

• Besides assigning formats by hand, however, you can assign them to cells from 
the get-go and spare yourself the trouble of entering dollar signs, commas, 
percent signs, and other extraneous punctuation. 

• All you have to do is enter the raw numbers. Excel does the window dressing for 
you.



Formatting Numbers, Dates, and Time Values

• Excel offers five number-formatting buttons on the Home tab. Select cells with 
numbers in them and click one of these buttons to change how numbers are 
formatted:

1) Accounting Number Format: Places a dollar sign before the number and gives it 
two decimal places. You can open the drop-down list on this button and choose 
a currency symbol apart from the dollar sign.

2) Percent Style: Places a percent sign after the number and converts the number 
to a percentage.

3) Comma Style: Places commas in the number.

4) Increase Decimal: Increases the number of decimal places by one.

5) Decrease Decimal: Decreases the number of decimal places by one.



Formatting Numbers, Dates, and Time Values

• To choose among many formats and to 
format dates and time values as well as 
numbers, select the cells, go to the Home 
tab, and use one of these techniques:

➢Open the Number Format drop-down list 
and select an option.

➢ Click the Number group button and make 
selections on the Number tab of the 
Format Cells dialog box. Choose a category 
and select options to describe how you 
want numbers or text to appear. You can 
also open the Format Cells dialog box by 
right-clicking and choosing Format Cells 
on the shortcut menu.
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